Repository navigation
Keep security updates compatible with PHP 7.4 - #67
Merged
Merged
Conversation
|
Coverage report for commit: f089e95 Summary - Lines: 89.84% | Methods: 65.22%
🤖 comment via lucassabreu/comment-coverage-clover |
||||||||||||||||||||||||||||
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Dependabot’s Guzzle, PSR-7 and PHP_CodeSniffer security updates cannot resolve the old development lock against the SDK’s published PHP 7.4 minimum: php-coveralls locks
psr/log 2.0.0, which requires PHP 8.Resolve development dependencies at PHP 7.4 and refresh the lock to compatible patched releases. Set safe development floors for Guzzle, PSR-7, PHPUnit and PHP_CodeSniffer. Keep the public requirement at
php >=7.4.0and all six existing CI cases; add a PHP 7.4.33 locked case and validate locked installations against the actual runtime.The PHP 7.4 run also exposed an existing invalid-HMAC warning before the intended exception. Validate the algorithm first so the existing regression test receives
InvalidArgumentExceptionconsistently on PHP 7 and 8.Validation:
f089e950, including the native PHP 7.4 install, API system tests and coverage.Advisory floors: Guzzle 7.15.2, PSR-7 2.12.3, PHP_CodeSniffer 3.13.6. PHP’s HMAC warning/exception change explains the compatibility guard.
🤖 Claimed by kvz on
framework1/php-sdksince 2026-10-22 · resume:codex resume 01a16227-a911-7581-be2f-48cb694033e9