You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
As a serviceprovider I want to set a pool quota so I can issue a quota-fixed invoice.
Value
support saas businesses
Acceptance Criteria
add new config option to set an instance-wide pool quota
disabled by default (disabled = current behaviour, limit is max. available storage space)
change existing wording quota -> "Unrestricted" to "Pooled - No individual limit"
pool quota is enforced upon storage-consumption: once actual usage reaches the pool quota, writes are rejected instance-wide, regardless of remaining individual quota (edge-case)
user-facing error must state the pool is full, not the personal quota
personal/space quota is a cap, not a reservation
a single cap must be <= pool quota, larger values can not be selected
the sum of all caps may exceed the pool quota (overcommit), (this is intended to encourage users to use the cloud-storage)
edgecase overcommit: a user can hit the pool limit while the ui still shows free personal quota, needs info-message, tbd
if overprovisioned: show a note "Allocated quota exceeds pool quota by X (Y%). Actual usage stays limited to the pool quota."
enabling the pool on an existing instance - tbd, eg:
existing caps above the pool quota are capped to the pool quota, admin sees the affected entries before applying
disabling the pool: caps remain and stay in effect, limit is max. available storage space again
Description
User Stories
Value
Acceptance Criteria
add new config option to set an instance-wide pool quota
change existing wording quota -> "Unrestricted" to "Pooled - No individual limit"
pool quota is enforced upon storage-consumption: once actual usage reaches the pool quota, writes are rejected instance-wide, regardless of remaining individual quota (edge-case)
personal/space quota is a cap, not a reservation
edgecase overcommit: a user can hit the pool limit while the ui still shows free personal quota, needs info-message, tbd
if overprovisioned: show a note "Allocated quota exceeds pool quota by X (Y%). Actual usage stays limited to the pool quota."
enabling the pool on an existing instance - tbd, eg:
disabling the pool: caps remain and stay in effect, limit is max. available storage space again